Устранение проблем с Parallels Tools

5 users found this article helpful

Симптомы

При установке/переустановке/обновлении Parallels Tools возникают различные неисправности.

В виртуальных машинах не работают некоторые или большинство функций Parallels Tools.


Примечание. Инструкции по установке, переустановке и обновлению Parallels Tools доступны в Руководстве пользователя Parallels Desktop 9 для Mac.


Решение

Шаг 1. Выберите наиболее точное описание вашей ситуации:

В виртуальных машинах не работают некоторые или большинство функций Parallels Tools:

Примечание. Никогда НЕ запускайте prl_cc.exe (Parallels Control Center) как администратор. Это вызовет много дополнительных проблем с компонентами Parallels Tools.

Смотрите шаг 2.1.

 

Не удается установить Parallels Tools. Появляется окно с сообщением: 'При обновлении Parallels Tools возникла ошибка'

Смотрите шаг 2.2.

 

Мастер установки Parallels Tools запускается, но через некоторое время дает сбой. Появляется окно с сообщением: 'Ошибка [xxx]. [описание ошибки]'

Смотрите шаг 2.3.

 

Мастер установки Parallels Tools запускается, но через некоторое время откатывает все изменения. Появляется окно с сообщением: 'Ошибка [xxx]. [описание ошибки]'

Смотрите шаг 2.4.

 

Виртуальная машина имеет виртуальный дисковод CD, но в окне Мой компьютер он не показывается. Невозможно установить Parallels Tools.

Попробуйте найти решение здесь: https://kb.parallels.com/5076

 

Невозможно установить аудиодрайвер Parallels в виртуальной машине с Windows XP

Попробуйте найти решение здесь: https://kb.parallels.com/9324

 

После каждого запуска Windows XP появляется сообщение "Обнаружено новое устройство"

Одно из решений - удалить USB-мышь. Смотрите статью: https://kb.parallels.com/9322


Другие проблемы с установкой Parallels Tools

Попробуйте найти решение в следующей статье: https://kb.parallels.com/8969

При попытке установить Parallels Tools ничего не происходит - даже после выполнения инструкций из руководства пользователя Parallels Desktop для Mac.

Пожалуйста, следуйте инструкциям в этой статье: https://kb.parallels.com/112609

 

Шаг 2.1. В виртуальных машинах не работают некоторые или большинство функций Parallels Tools

Убедитесь, что Parallels Tools действительно установлены: Пуск > Панель управления > Установка и удаление программ > Parallels Tools.

Если нет, сделайте следующее:

Установите Parallels Tools с помощью пункта "Установить Parallels Tools" в меню "Действие" (Parallels Desktop 2 и 3) или "Виртуальная машина" (Parallels Desktop 4 и выше / Parallels Workstation 2.2 и Extreme).

Перезапустите Windows.

Если Parallels Tools уже установлены, переустановите их. Как это сделать, смотрите в следующих статьях: KB 115776KB 4841


Шаг 2.2. Во время установки Parallels Tools появляется сообщение: 'При обновлении Parallels Tools возникла проблема'

Файл /Библиотеки/Parallels/Tools/prl-tools-win.tar.gz отсутствует или поврежден.
Пожалуйста, переустановите Parallels Desktop.
Если это первая установка Parallels Tools на данной виртуальной машине, убедитесь, что в папке /Библиотеки/Parallels/Tools/ существует файл prl-tools-win.iso.

Если файл на месте, убедитесь, что он подключен к виртуальной машине. Для этого откройте меню Устройства > CD/DVD и подключите его, как описано в этой статье: https://kb.parallels.com/111743

Если файл отсутствует, переустановите Parallels Desktop.

Чтобы получить точное сообщение об ошибке, выполните ручную установку Parallels Tools, как описано в статье 111730, 112609и переходите к шагу 2.3.

Если предыдущие шаги не помогли, пожалуйста, обратитесь в службу поддержки Parallels

 

Шаг 2.3. Известные коды ошибок

Сообщения об ошибках часто содержат внутренний код ошибки. Ниже перечислено несколько известных кодов.

Статья: 9379

Ошибка 1402 или 1406

Error 1402: (Could not open key: HKEY_Local_Machine32\Software\Microsoft\Windows\CurrentVersion\InternetSettings\ZoneMap\Domains\psf)

ИЛИ

Error 1402: (Could not open key: HKEY_Local_Machine32\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\InternetSettings\ZoneMap\Domains\psf)



Статья: 6891

Ошибка 1935 с текстом "HRESULT: 0x080070057/ 0x800736FD/ 0x80070BC9": 

Error 1935. An error occurred during the installation of assembly component {98CB24AD-52FB-DB5F-A01F-C8B3B9A1E18E}. HRESULT: 0x80070BC9

 

Статья: 5736

Ошибка 2738 "Не удалось получить доступ к выполнению VBScript для пользовательского действия"
"Failed to marshal script action"  (в Windows 2000)


Статья: 114744

Ошибка 110 "Системе не удается открыть указанное устройство или файл." 


Шаг 2.4. Откат установки

Иногда установка Parallels Tools останавливается на середине и затем откатывается обратно без каких-либо сообщений об ошибке. Мастер установки может выдать предупреждение о том, что установка не удалась и требуется перезагрузка. В таких случаях нужно посмотреть, что написано в файле parallels-tools-setup-xxx.log в папке C:\WINDOWS\Temp.

Перейдите в конец файла. Убедитесь, что последняя строка содержит актуальную дату и время из Windows:

    "=== Verbose logging stopped: 7/4/2011 14:13:04 ==="

Если в одной из предыдущих строк написано Return code 3010, значит, все в порядке. Parallels Tools были успешно установлены.

    "MainEngineThread is returning 3010" 

Запись Return code 1603 означает, что установка не удалась. Обратите внимание, что сообщение "Info 1603" - это не сама ошибка!

Найдите начало текущего журнала. Прокрутите вверх - до предыдущей записи "Verbose logging started". Убедитесь, что в начале журнала правильно указаны дата и время.

    "=== Verbose logging started: 10/28/2010 15:38:10 Build type: SHIP UNICODE 5.00.7600.00 Calling process: C:\Windows\SysWOW64\msiexec.exe ==="

Найдите первое упоминание слова "Rollback:" в начале строки. Найдите код ошибки чуть выше строки, начинающейся с "Rollback:"

 

Error 1627:

Найдите следующие строки:

    DIFXAPP: ERROR: InstallDriverPackages failed with error 0x65B 
    DIFXAPP: RETURN: InstallDriverPackages() 1627 (0x65B)

Удалите раздел реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\FileScreenFilter.

 

Error code 0xE0000100:

    Error code 0xE0000100: The style of the INF is different than what was requested

https://kb.parallels.com/9388

 

Error code 0x3

    Error code 0x3: The system cannot find the path specified Could not open file
    C:\Windows\System32\DriverStore\FileRepository\prl_mouf.inf_x86_neutral_2209e2708eaa50e2\prl_mouf.inf. 
    (Error code 0x3: The system cannot find the path specified.)

https://kb.parallels.com/9388

 

Шаг 2.5. Отправьте отчет о проблеме:

Если проблема все равно не исчезла или у вас возникли сложности на одном из описанных выше этапов, пожалуйста, отправьте отчет о проблеме с помощью меню Справка > Сообщить о проблеме.

Запишите номер отчета и сохраните его для службы поддержки.

Обратитесь в службу поддержки Parallels.

Примечание. Чтобы ускорить устранение проблемы, при создании заявки на поддержку сообщите, пожалуйста, номер отчета о проблеме и результаты описанной выше диагностики.

Причина

Большинство проблем с установкой Parallels Tools вызваны неправильными настройками Windows.


 


Также смотрите:

Was this article helpful?

Tell us how we can improve it.