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Unable to login to Parallels Desktop after macOS update. The error message 'Check your Internet connection and try again.'

APPLIES TO:
  • Parallels Desktop for Mac Home Edition
  • Parallels Desktop for Mac Pro Edition

Symptoms

After installing the latest upgrade I'm prompted to login with my Parallels account. When I try doing so an error message shows up: "Check your Internet connection and try again. If the problem persists, follow this link to register your copy of Parallels Desktop.". The Internet connection is fine.

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Cause:

The Parallels Engineering Team is aware of this issue and working on the resolution. To supply them with the information needed to hasten this process follow these steps:

  1. Quit Parallels Desktop.

  2. Open Terminal (Finder - Applications - Utilities - Terminal)

  3. Insert the following commands one by one and hit return/Enter after each:

    sudo su
    

    NOTE: No symbols will be shown due to security measures, so just hit the keys and use return/Enter.

    ls -lOae@ /private/var/root/Library/Preferences/com.parallels.desktop.plist
    ls -lOae@ /private/var/root/Library/Preferences
    ls -lOae@ /private/var/root/Library
    ls -lOae@ /private/var/root
    ls -lOae@ /private/var
    ls -lOae@ /private
    ls -lOae@ /
    
  4. Copy the output of these commands to some text file and share it with Parallels Desktop Support Team.

Resolution

Only after processing the steps above execute the following Terminal commands (the latter command will restart the Mac to apply changes):

    sudo rm -rfd /private/var/root/Library/Preferences/com.parallels.desktop.plist
    sudo reboot

Type in your Mac password.

NOTE: No symbols will be shown due to security measures, so just hit the keys and use return/Enter.

After restarting the Mac, it's required to verify and repair Mac's disk file system using Disk Utility application, because in most of the cases the root cause of the issue related to issues within the file system:

  1. Launch Disk Utility application ( Applications - Utilities - Disk Utility).
  2. Select a disk in question (its name Macintosh HD by default, if the disk wasn't renamed) and then click on First Aid button.
  3. Once suggested by the application, press Run button to start the process of verification and repair.
  4. Press Continue button to proceed.
  5. Wait until the process is completed and click Done button to finish the operation
  6. Start Parallels Desktop and try to login again using corresponding credentials.
  7. If this solution does not help, contact Parallels Desktop Support Team.



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