Симптомы
Не удается запустить Parallels Desktop. На экране появляется окно с уведомлением: Не удалось запустить службы Parallels.
Причина
- Parallels Desktop не может подключиться к одной из запрошенных служб.
- Произошел сбой аутентификации расширений ядра системы.
- Parallels Desktop не может получить доступ к расширениям ядра системы.
- Операционная система macOS® не позволяет загружать расширения ядра Parallels Desktop из-за системной политики.
Устранение неполадок
Примечание. Данное поведение было исправлено в macOS® Catalina и более новых версиях. Таким образом, в качестве первого шага рекомендуем обновить версию macOS® как описано в данной статье. Если это не представляется возможным, выполните шаги ниже для того чтобы попробовать исправить проблему.
В качестве первого шага перезапустите компьютер Mac, перезапустите Parallels Desktop, а затем попробуйте переустановить ее.
- Перезапустите Mac и попробуйте снова перезапустить Parallels Desktop.
- Если это не помогло, переустановите Parallels Desktop.
ПРИМЕЧАНИЕ. Для окончания процесса переустановки необходимо перезапустить компьютер. - После перезапуска Mac снова установите Parallels Desktop. При необходимости скачайте образ установки со страницы Загрузки для Parallels Desktop.
- Попробуйте снова запустить Parallels Desktop.
Если шаги выше не исправили ситуацию, пожалуйста, откройте Терминал (Finder > Приложения > Утилиты > Терминал) и выполните команду ниже:
ls -Ol /private/var/db/ | grep 'restricted'
Проверьте текст результата команды. В одной из строчек Вы должны увидеть название папки KernelExtensionManagement. Если Вы не видите такой папки, пожалуйста, выполните следующие шаги:
-
Загрузите Вам Mac в режиме восстановления. Для этого выключите его, затем включите снова и удерживайте клавиши Command+R на клавиатуре, пока на экране не появится логотип Apple. Затем просто дождитесь загрузки.
Примечание. Если вместо окна "Утилиты" отображается окно входа, возможно, вы нажали Command+R поздно. Перезапустите компьютер Mac и повторите попытку. -
После загрузки в режиме восстановления, запустите Дисковую Утилиту и проверьте имя Вашего жесткого диска. По умолчанию это Macintosh HD.
-
Закройте Дисковую Утилиту и в верхней панели нажмите Утилиты > Терминал.
-
В Терминале выполните команду ниже:
chflags restricted "/Volumes/Macintosh HD/private/var/db/KernelExtensionManagement"
Пожалуйста, обратите внимание, что если название диска Вашего Mac отличается от Macintosh HD, то данную команду необходимо скорректировать соответствующим образом.
- Перезагрузите Ваш Mac, нажав на логотип Apple > Перезагрузить...
Дополнительные действия по поиску и устранению проблем
- Запустите Терминал: откройте Finder - Программы - Утилиты - Терминал.
-
Выполните следующую команду:
sudo kextcache --clear-stagingПримечание. Для выполнения этой команды необходимо будет ввести пароль входа на компьютер Mac. Из соображений безопасности символы не отображаются при вводе, поэтому просто введите пароль и нажмите клавишу ВВОД.
-
Попробуйте запустить Parallels Desktop. Если не удалось разрешить проблему, выполните следующую команду:
sudo touch /System/Library/ExtensionsПримечание. Для выполнения этой команды необходимо будет ввести пароль входа на компьютер Mac. Из соображений безопасности символы не отображаются при вводе, поэтому просто введите пароль и нажмите клавишу ВВОД. -
Перезапустите Mac и попробуйте снова запустить Parallels Desktop.
-
Если не удалось разрешить проблему, перезапустите Mac и удерживайте клавиши Command+R на клавиатуре, пока на экране не появится логотип Apple.
Примечание. Если вместо окна "Утилиты" отображается окно входа, возможно, вы нажали Command+R поздно. Перезапустите компьютер Mac и повторите попытку. -
В верхней строке меню выберите Утилиты, а затем — Терминал.
-
Выполните следующую команду:
spctl kext-consent add 4C6364ACXT
Примечание. После ввода команды нажмите клавишу ВВОД, чтобы выполнить ее.
-
Результат выполнения команды должен выглядеть следующим образом:
-
Чтобы перезапустить Mac в обычном режиме, выполните команду
reboot
или выберите логотип Apple > Перезапустить… - Попробуйте снова запустить Parallels Desktop.
- Если ни одна из приведенных выше процедур не помогла разрешить проблему, остается только переустановить macOS® с раздела восстановления, чтобы обновить системные файлы. Инструкции по переустановке см. в этой статье. При переустановке macOS® с раздела восстановления обновляются только системные файлы, а личные файлы и установленные приложения остаются неизменными.
Использование MDM для развертывания Parallels Desktop
При установке Parallels Desktop в корпоративной среде отключите инструмент MDM или проверьте его настройки. Он может блокировать установку расширения, если для управляемого профиля включены определенные настройки.
Информацию о настройке профиля MDM для использования с Parallels Desktop см. в документе Parallels Desktop for Mac Business Edition IT Administrator's Guide (Руководство ИТ-администратора Parallels Desktop для Mac Business Edition) (стр. 31)
Was this article helpful?
Tell us how we can improve it.