症状
- ゲートウェイまたはゲートウェイ SSL モードを使用している。
公開アプリケーションの接続時に下記のエラーが発生する。
[4612] - ネットワークエラーのため接続が終了しました。リモートコンピューターに再接続してください。
原因
ターミナルサーバー上のリモートデスクトップサービスが起動していない。
- ターミナルサーバーエージェントがシステムの RDP ポートに一致していない。
原因
ターミナルサーバー上で Remote Desktop Services が実行されていない。
- ターミナルサーバーエージェントのポートが システムの RDP ポートと一致していない。
解決策
ターミナルサーバー上で Windows サービス (services.msc) を開き、Remote Desktop Services を開始します。
ターミナルサーバー上で 下記のレジストリエントリを確認します:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber
- 10進数の値が、RAS コンソール > ファーム > ターミナルサーバー > ターミナルサーバー プロパティ > Agent 設定 > ポート の値と一致していることを確認します。
注意: システムの RDP ポートを最近変更した場合には、Remote Desktop Services サービスの再起動が必要となります。
Was this article helpful?
Tell us how we can improve it.