PARALLELS TOOLS: RISOLUZIONE DI PROBLEMI

3 users found this article helpful

Problema

Si possono riscontrare diversi problemi durante l'installazione /reinstallazione/aggiornamento di Parallels Tools.

Causa

Parallels Tools potrebbe presentare problemi durante l'installazione a causa di diversi motivi, la maggior parte dei quali sono relativi ad errori nella configurazione di Windows.

Risoluzione

Al fine di determinare il modo appropriato di risolvere il problema d'installazione di Parallels Tools, leggi accuratamente le istruzioni in basso:

Passaggio 1.  Cerca la situazione esatta del problema:


 
  Vai al Passaggio 2.1

  Vai al Passaggio 2.2

  Vai al Passaggio 2.3

Puoi trovare una soluzione qui: https://kb.parallels.com/5076

Trova la soluzione qui:https://kb.parallels.com/en/9324

Una delle soluzioni è rimuovere il dispositivo del mouse USB. Consultare il seguente articolo KB: https://kb.parallels.com/en/9322

Puoi trovare una soluzione nel seguente articolo KB: https://kb.parallels.com/8969


Passaggio 2.

2.1 Installazione di Parallels Tools non riuscita, con il messaggio di errore: 'Parallels Tools Installation Agent' 'Si è verificato un problema durante l'aggiornamento di Parallels Tools'


Se il file è presente, verifica che sia connesso alla macchina virtuale.
Per farlo, vai sul menu Dispositivi - CD/DVD e connettilo alla macchina virtuale, come descritto in questo articolo del KB: https://kb.parallels.com/en/111743

 Se questo file non è presente, reinstalla Parallels Desktop. 

Passaggio 2.2.Codici di errore conosciuti 
Spesso, quando compare un messaggio di errore, contiene un codice di errore interno.  Alcuni codici di errori noti si riportano in basso.

Articolo KB: https://kb.parallels.com/en/9379

Articolo KB: https://kb.parallels.com/en/6891

Consultare il seguente articolo della base di conoscenza di Microsoft https://support.microsoft.com/kb/249873  per registrare una libreria Microsoft OLE Automation OLEAUT32.DLL usando Regsvr32:
 

regsvr32 oleaut32.dll


Passaggio 2.3. Rollback
Alcune volte l'installazione di Parallels Tools si arresta nel mezzo della procedura e quindi esegue il rollback senza un messaggio di errore. L'installazione guidata di Parallels Tools potrebbe solo avvisare sull'errore d'installazione e richiedere il riavvio.
In questi casi, è necessario controllare il file parallels-tools-setup.log che si trova nella cartella C:\WINDOWS\Temp.

Vai alla fine del file. Accertati che l'ultima stringa contenga la data e l'ora attuali di Windows: 

"=== Verbose logging stopped: 7/4/2011 14:13:04 ==="

 

Il codice di ritorno 3010 in una delle stringhe precedenti significa OK. Parallels Tools è stato correttamente installato. 

"MainEngineThread is returning 3010"

  Il codice di ritorno 1603 significa 'non riuscito'. Tieni presente che il messaggio "Info 1603" non è l'errore stesso!

Cerca nell'inizio del corrente registro. Spostati verso la voce precedente "Verbose logging started". Accertati che la data e l'ora dell'inizio del registro siano attuali.

"=== Verbose logging started: 10/28/2010 15:38:10 Build type: SHIP UNICODE 5.00.7600.00 Calling process: C:\Windows\SysWOW64\msiexec.exe ==="

 

Cerca la prima voce del messaggio  "Rollback:" come primo simbolo nella stringa. Guarda il codice di errore in alcune stringhe sopra questo "Rollback:"

Errore 1627: 
Cerca le seguenti stringhe:

DIFXAPP: ERRORE: InstallDriverPackages failed with error 0x65B
    DIFXAPP: RETURN: InstallDriverPackages() 1627 (0x65B)


La soluzione per questo problema può trovarsi qui.

Codice di errore 0xE0000100: Lo stile di INF è diverso di quello richiesto
https://kb.parallels.com/en/9 388 

Codice di errore 0x3: Il sistema non può trovare il percorso specificato

Could not open file C:\Windows\System32\DriverStore\FileRepository\prl_mouf.inf_x86_neutral_2209e2708eaa50e2\prl_mouf.inf. (Error code 0x3: Il sistema non può trovare il percorso specificato.)


https://kb.parallels.com/en/9388  

Was this article helpful?

Tell us how we can improve it.