Requirements for installing RAS Performance Monitor
- RAS Performance Monitor can be installed on 64bit OS only.
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Make sure that the port TCP 3000 is opened and not occupied by any 3rdparty app.To view performance metrics, the Parallels RAS administrator uses the dashboard (Grafana, port TCP 3000), which displays the visual representation of performance counters in real time.
- We do recommend to install RAS Performance Monitor on dedicated server.
- On the servers which will be monitored it is required to open port TCP 8086. RAS Telegraf service collecting a predefined set of performance counters at a fixed time interval (10 seconds). It then sends the collected data to the InfluxDB database (to the machine where RAS Performance Monitor installed) for storage using port TCP 8086
Troubleshooting tips
Issue #1:
Server is not sending/stopped sending performance data and as result you can't see CPU/Memory usage in Monitoring tab.
Cause
- RAS Telegraf service is not running on the affected server.
- Port TCP 8086 is blocked on the affected machine.
Resolution
Please make sure that RAS Telegraf service is running on the problematic machine and the port TCP 8086 is opened.
NOTE: If you just started the service, please wait for at least 5-10 minutes until RAS Performance Monitor starts displaying updates.
Issue #2:
Monitoring section in RAS Console is not showing any dashboard and throwing an error that the information cannot be displayed.
Cause
- Port TCP 3000 cannot be used by RAS Performance Monitor.
- Corrupted installation of RAS Performance Monitor.
Resolution
1) Please make sure that port TCP 3000 is not occupied by some other process. You can verify it by opening localhost:3000 in you web browser. If all is working fine you should be able to see and use the dashboard:
2) Try to reinstall RAS Performance Monitor.
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