Symptoms
- Few users reports that printer redirections takes an abnormal amount of time.
- "Cache printers hardware information" enabled in Parallels Client > Tools > Options > Advanced settings
- Extended client log contains the following strings:
[Error in database on execute, error: 11/11, msg: 'malformed database schema (tbl_FontsCache)' command: (CREATE TABLE tbl_TableVersion (tbl_Name TEXT NOT NULL PRIMARY KEY UNIQUE DEFAULT (''),tbl_Version FLOAT DEFAULT 0,tbl_Type TEXT DEFAULT (''),tbl_Locked INTEGER DEFAULT 0);)
Failed to initializeDB. Conn string: ClientCache.db (1)
Initialization of printers cache database failed.
Failed to initializeDB. Conn string: ClientCache.db (1)
Initialization of printers cache database failed.
Cause
ClientCache.db file is corrupted and causes Printer caching to fail. Due to this, printers may take a lot of time to redirect:
[D 08/00003000/T1014/P1D7C/S000A] 02-06-21 08:13:09 - Collecting printer info for: Canon
[D 08/00000000/T1014/P1D7C/S000A] 02-06-21 08:13:09 - Cache entry not found for printer: Canon
[W 08/40003000/T1014/P1D7C/S000A] 02-06-21 08:18:13 - Skip paper '' (index 256) with size 2159x2794
[D 08/00000000/T1014/P1D7C/S000A] 02-06-21 08:13:09 - Cache entry not found for printer: Canon
[W 08/40003000/T1014/P1D7C/S000A] 02-06-21 08:18:13 - Skip paper '' (index 256) with size 2159x2794
Resolution
Reinstall Parallels Client completely following this KB
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