Install .NET 3.5 Framework in Windows on a Mac with Apple M1 chip

23 users found this article helpful

Issue

Some applications in Windows running in Parallels Desktop on a Mac with Apple M1 chip require .NET 3.5 framework to be installed. However, its installation can fail with the 0x800F0950 error. 

Resolution

To install .NET 3.5 framework in a Windows virtual machine in Parallels Desktop on a Mac with Apple M1 chip, you should be running the latest Windows Insider Preview Dev Channel build.

To do that, perform the following steps:

  1. Follow the steps from KB 125526 to install the latest Windows 10 Insider Preview updates.
  2. Once the updates have been installed, install .NET 3.5 framework: press Command+R, and in the "Run" prompt paste optionalfeatures and click OK.

  3. In the "Windows Features" window tick .NET framework 3.5 (includes .NET 2.0 and 3.0) and click OK.

  4. Click Let Windows Update download the files for you to proceed with installing .NET framework 3.5

Was this article helpful?

Tell us how we can improve it.