Symptoms
Application session recording doesn't work.
Cause
- Incorrectly configured URL.
- Network connectivity.
- Share/folder permissions.
In case of an incorrectly configured URL, in the log files a similar error will be visible:
Apr 13 09:18:47 awhost001 manage.py[39644]: Uploading recording failed, file: /var/lib/awingu-application-gateway/recorded-sessions/fda3a212-4bde-4793-b2d8-4622f4cdc5fa_89cd0b4b-fcec-4fa0-b40f-550d5df88dce.rdpv
Traceback (most recent call last):
File "/opt/awingu/awingu-core/virtualenv/lib/python3.6/site-packages/awingucore/tasks/tasks.py", line 154, in upload_record
protocol, protocol_params = parse_drive_url(url)
File "/opt/awingu/awingu-core/virtualenv/lib/python3.6/site-packages/awingucore/tasks/tasks.py", line 67, in parse_drive_url
domain_name, username = username.split('\\')
AttributeError: 'NoneType' object has no attribute 'split'
Other causes will have other error messages in the log files.
Resolution
- Go to System Settings > Configure > User Connector and scroll down to the Application session recording section.
- Validate the Recordings Upload URL.
- Only SMB/CIFS and HTTP (WebDAV) are supported. HTTPS is not supported.
- SMB example: smb://DOMAIN\username:password@server:port/path/to/save
Note that DOMAIN should match an Awingu domain name, which might be different from the NetBIOS name, and must be uppercase.- Mind that when specifying the username and password,
- HTTP example: http://username:password@server:port/path/to/save
- SMB example: smb://DOMAIN\username:password@server:port/path/to/save
- Only SMB/CIFS and HTTP (WebDAV) are supported. HTTPS is not supported.
- If still not working:
- Validate the permissions for the specified user (in the URL) at the target server.
- Validate connectivity.
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