Troubleshooting issues related to Shared Applications (from Windows to Mac)

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Symptoms

Cause

Some requirements for shared Applications are not met.

Resolution

Please check the following:

  1. Parallels Tools are installed and all components are of the latest versions.
  2. 'prl_cc.exe' process is running and has administrative privileges.
  3. In the virtual machine options, check if Application Sharing is enabled.
  4. Make sure that Parallels Desktop is able to create a folder with Shared Applications.
  5. Make sure that appropriate file associations are set up on Mac side.

Instructions on how to do that:

1. Parallels Tools are installed and all components are of the latest versions. Parallels Tools are main component when it comes to sharing just about anything, including applications.

To check if you have Parallels Tools installed and ready, perform the following:

1.1. In Mac menu bar, click 'Virtual machine'. If it says 'Install Parallels Tools', you can click it and start installation.

1.2. If it says 'Reinstall Parallels Tools' than Parallels Tools are installed (it does not guarantee complete or functional installation).

1.3. Another indicator is 'View' menu. If 'Enter Coherence' is unavailable, then Parallels Tools installation is malfunctioning.

1.4. To check if all components are of the latest version, generate a problem report 'Help'->'Problem report...'but do not send it.

1.5. Press 'Details...' and look for 'GuestOS' node. It should display several <ToolVersion/> nodes with Parallels Tools components versions.

1.6. All of those versions should be equal to your Parallels Desktop version (you can check it in 'Parallels Desktop' -> 'About Parallels Desktop' except for the anti-virus nodes (Kaspersky, DrWeb, etc). There should be about 48 nodes total for Windows guest.

1.7. If you see that all components of Parallels Tools are installed properly but something is still wrong with Mac-to-Windows application sharing (for example, the folder %appdata%\Parallels\Shared Applications is empty), please reinstall Parallels Tools. Also, you can use Microsoft FixIt to remove Parallels Tools completely and reinstall them.

If you experience any problems with Parallels Tools please check the following article for troubleshooting: Parallels Tools Troubleshooting

2. 'prl_cc.exe' process is running and has administrative privileges.

Refer to this article for steps on how to fix (relevant for both Windows 7 and 8, relevant for XP too but everything looks different there): http://kb.parallels.com/117984

3. In the virtual machine options, check if Application Sharing is enabled.

3.1. Go to virtual machine configuration as described in this article: http://kb.parallels.com/en/117287

3.2. On the 'Options' tab, select 'Applications'. Make sure 'Share Windows Applications with Mac'.

3.3. If you experience problems with Shared Applications folder (in Dock or otherwise), you can try unchecking these ticks ('Share apps' and 'Folder in Dock') and checking them back.

3.4. Also you can try rebooting in between these manipulations.

4. Make sure that Parallels Desktop is able to create a folder with Shared Applications.

Parallels Desktop has two folders where it stores application links:

'/Users/username/Library/Parallels/Application Menus'...

After that goes name for virtual machine (or in some cases its GUID). This folder stores application link representations in the Dock and is used only when to-Dock sharing is enabled.

'/Users/username/Applications (Parallels)'...

After that goes name for virtual machine (or in some cases its GUID). This folder contains actual links to applications in Windows.

In case of any problems with (or after) clicking on the application link on Mac, you need to check:

4.1. Parallels Desktop (the user it is run under) has full access to the above folders and all subfolders and parent folders. You can check permissions for individual item by right-clicking it and choosing 'Get Info...'.

4.2. You can try deleting these folders and then restarting virtual machine to have them re-created (and fixed).

4.3. If they do not re-create themselves, then there is some issue with permissions or 'prl_cc' is not running or Parallels Tools integrity is compromised. Additionally, you can check logs for errors (no definite message to look for. Look for nearest time stamps).

Additionally, if you can launch most applications from the aforementioned folder but have trouble with some specific application (error is displayed when clicking on a link or no link is present at all when other links are there), you may try to login to Windows and open your application from Windows side once. This should alert 'prl_cc' of its presence once again and cause the link to be created on Mac side (provided there are no permission issues discussed before).

5. Make sure that appropriate file associations are set up on Mac side.

If you are sure that folders with application links and all other necessary components are OK (you can launch Windows applications from Dock and from folders themselves) but opening some file with Windows application (like .doc file with Word from Windows) still does not work (there is an error or nothing happens), there may be a problem with file associations on Mac itself.

To fix file associations:

5.1. Find a file of type (for example: .doc) which has trouble opening in Windows application from Mac.

5.2. Right-click it and choose 'Get Info...'

5.3. In the 'Open with:' dropdown menu, select 'Other...'. Set 'Enable' to 'All applications'

5.4. Navigate to the folder mentioned in previous step: '/Users/username/Applications (Parallels)'

5.5. Find the folder corresponding to your virtual machine and open it. All its applications should be in this folder.

5.6. Select the application you wish to open file with.

5.7. If you cannot see the 'Applications (Parallels)'folder when searching for the application, you can use Finder's 'Go'->'Go to Folder...' (this will open a new Finder window) to type in the full path to it.

5.8. After that, you can drag the folder from new Finder window to the previous window where you are selecting the application for file type. It will change its path automatically.

5.9. Additionally, before pressing 'Add', you can tick 'Always Open With' to set the selected application for all files of a single type (of .doc for example) on your Mac system.

6. After performing all of the above steps:

Shared applications should work correctly on your setup. If there still appears to be an issue with opening Windows applications from Mac (including issues in Coherence mode), you can contact Parallels Technical Support via website: http://www.parallels.com/support/desktop-virtualization/desktop/

You can find more information about requesting support in this article: http://kb.parallels.com/en/6571

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