Symptoms
1. From time to time, the Client session got disconnected with the following errors:
- Windows Client
RDP session ended [0x0000010B][0x00000000][0x0000010B] [MsTscAx] Your Remote Desktop Services session has ended. The connection to the remote computer was lost, possibly due to network connectivity problems. Try connecting to the remote computer again. If the problem continues, contact your network administrator or technical support.
-MacOS Client
RDP session to 10.4.30.201 ended [0x00000404][0x00010003] The connection was ended because of a network error. Please try connecting to the remote computer again.\
2. As entry-point to your RAS Environment, an Azure Network Load Balancer is used
3. Your RAS Gateways servers (behind Azure NLB) are V5 VM versions (regardless to series and size)
Cause
It's confirmed that to the date March 2024, there is an issue in underlying hardware for V5 racks, what is causing a routing switch (enables Azure NLB) to randomly drop network packets.
Resolution
1. Remove Azure NLB to verify that this is the cause (point to the RAS GW directly)
2. Change version of RAS GW machine to some different from V5. The issue was resolved by changing it to V4, this will move VMs to a different underlying infrastructure in Azure Datacenter.
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