Symptoms
Unable to open a file from the Files tab in an application that's been published.
Cause
Main causes:
- On the Microsoft Windows Server, the RemoteApp is not properly configured.
- Unsupported drive. This feature is only available for files accessed through a CIFS-based drive.
Resolution
- Validate if the files are provided through a CIFS-based drive.
- When the user wants to open a file with an application, they either single click/tap or use the Open File action in the Files tab.
When opening a file in the Files tab, it should allow opening the file using the associated application.
If the application is not listed, it means that no applications have been associated with this file type.- Go to the System Settings > Manage > Applications.
- Edit the application that should open the file.
Assign the file types that this application can open and press [Apply].- If the file type you need to assign is not available in this list, go to System Settings > Manage > File Types, to add additional file types/extensions.
- If the file type you need to assign is not available in this list, go to System Settings > Manage > File Types, to add additional file types/extensions.
- The UNC path (System Settings > Manage > Drives > Select your drive > UNC) is used to open the file using a RemoteApp or RDP app.
Make sure the UNC path is correctly configured, and the path is reachable from the application server.
- By default, RemoteApps on the Microsoft Windows RDS server are published without allowing command line arguments.
It's required to Allow any command-line parameters in the remote application configuration on the RDS server for this feature to work, because Parallels Secure Workspace sends the UNC path of the file as a command to the RDS server/application.- Open Windows Server Manager > Remote Desktop Services > Open your Session Collection.
Right-click the application > Click Edit Properties.
- Go to the Parameters tab > Check Allow any command-line parameters. Apply this setting.
- Open Windows Server Manager > Remote Desktop Services > Open your Session Collection.
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