Symptoms
Pre-authentication redirection to the external Identity Provider (IdP) is not working, the login screen stays visible instead.
An error "Authentication for user failed: Pre-authentication required." is displayed when the user tries to sign in.
Cause
This issue is usually caused by a lack of host headers set in the Parallels Secure Workspace domain configuration.
Resolution
Log in using the built-in management user.
Alternatively: if multiple domains are configured in the Parallels Secure Workspace environment, log on (as an administrator) to an administrative domain in Parallels Secure Workspace where pre-auth is not required.
Go to System Settings > Global > Domains and select the affected domain.
Edit the domain and ensure the Host Headers field is configured. This needs to be set with the FQDN of the URL that is used to access the Workspace in the browser.
When users are accessing the environment using this URL, Parallels Secure Workspace needs to redirect the user to an external IdP for pre-authentication/Single Sign-On (SSO).
After configuring this setting, try navigating to the Workspace URL. You should be redirected to the external IdP.
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