Symptoms
Installation or update of Parallels Desktop gets stuck (often on "Removing the previous version").
Cause
A part of macOS® called Launch Services is not working correctly and needs to be restarted.
Solution
To restart Launch Services, do the following:
-
Restart your Mac®.
-
Go to Finder > Applications > Utilities > Terminal.
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Run these commands one by one:
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill
sudo /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill
After running this second command, you will be prompted for your password. Due to security measures no symbols will be shown, so just hit the keys and press Return/Enter.
sudo -u <username> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill
Instead of <username> enter your username that can be seen in the terminal before "$" sign.
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Run Parallels Desktop installation once again.
Alternative solution
The issue can also be caused by a misconfiguration in the macOS®.
In that case, the following steps may resolve the issue:
- Restart your Mac®.
- In macOS®, click Apple® logo > System Preferences > Users & Groups > Login Options > Edit
- One by one, select each available entry and click '-' to remove it.
- If Mac has multiple user accounts, sign in to each account and perform steps 1-3.
- Once the entries have been removed, run the installation.
If the steps above do not resolve the issue, please contact Parallels Support.
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