When you have one app started and then launch another, error "The remote computer has ended the connection" is thrown

0 users found this article helpful

Symptoms

When you have one app started and then launch another, error The remote computer has ended the connection is thrown:

However, both apps keep open.

Cause

Affected apps are published with different resolution settings:

RDP requires reconnection to the session if resolution changes.

Resolution

Please adjust the settings of apps to use the same resolution or configure the environment to run them in separate RD sessions:

1. Configure GPOs on RDS hosts to allow multiple sessions:
Set Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Connections\Restrict Remote Desktop Services users to a single Remote Desktop Services session to Disabled:

2. Disable option Limit each user to one session per desktop in RAS Console Load Balancing:

3. Enable option Disable session sharing for the apps requiring specific resolution:

Was this article helpful?

Tell us how we can improve it.