Symptoms
Mac is running slower after installing Parallels Desktop.
Cause
There could be several reasons:
- Unsupported hardware
- A lack of hardware resources
- An incorrect resource allocation to the virtual machine
Resolution
First of all please check if your computer meets Parallels Desktop system requirements:
https://kb.parallels.com/en/122662 for Parallels Desktop 10
https://kb.parallels.com/en/117047 for Parllels Desktop 9
Then, if you suspect a lack of resources on your computer, please try to adjust virtual machine settings:
- Allocate less RAM for the virtual machine.
- Options tab -> Optimization -> Performance -> set to Faster Mac.
If you suspect an incorrect resource allocation to the virtual machine side, then you need to identify applications on Mac that may consume too much resources:
- Restart Mac and ensure that Parallels Desktop is not running
- Open Finder and go to Applications Folder > Run Activity Monitor
- Click on the CPU tab, this will display the process that consumes the most CPU in descending order.
- Observe which process consumes the most CPU usage and take note of the its name.
- If your Mac has low performance at this point, the issue is not related to Parallels Desktop.
Or
- While observing the Activity Monitor, start Parallels Desktop and Windows virtual machine.
- Once Windows start, observe how the processes on the Activity Monitor fluctuates and take note of the process name.
- Upon starting Windows virtual machine, right/option click on the Task Bar and select Task Manager.
- Select the Processes tab from the Task Manager and click on CPU, this will display the process that consumes the most CPU in descending order.
- Observe which process consumes the most CPU. Once you have identified it, you can quit that program by selecting on it and clicking on End Process.
- Observe if Mac will freeze up at this point and how the Activity Monitor respond to the CPU usage.
If it is a resourse consumption:
Check the log messages in Console Utility:
Open Finder > Applications > Utilities > Console - If it is required click Show Log List - Select All Messages - In the search box type i/o - if it returns disk0s2: I/O error, your hard drive is corrupted and you need to contact Apple Support.
Also please check how much CPU usage is taken prl_vm_app process. If CPU amount is very high (>80%), please do the following:
First of all please check if any driver takes improper amount (>5000) of interruptions per second via this KB article
Make sure that your Virtual Machine configured to the best performance following this article.
Perform the test described in this KB article
- Start the virtual machine and turn off Antivirus and Firewall software on the both sides: Mac and Windows.
- Perform Selective Startup:
For Windows XP and Windows 7:
- Start virtual machine
- Go to Start > (for Windows XP: Start > Run >) in the search box type msconfig and hit Enter (return).
- In the System Configuration choose Selective startup and uncheck Load startup items. Click apply.
- In the Services tab UN-check Hide all Microsoft services, click Enable all, click Apply.
- Check Hide all Microsoft services, click Disable all, locate and check: Parallels Coherence Service and Parallels Tools Service (so 2 Parallels services should be checked), click Apply.
- In the Startup tab locate and check Parallels Tools (it can be called prl_cc).
- Click Apply and reboot your virtual machine normally.
For Windows 8:
- Start virtual machine
- Go to Start > in the search box type msconfig and hit Enter (return).
- In the System Configuration choose Selective startup and uncheck Load startup items. Click Apply.
- In the Services tab UN-check Hide all Microsoft services, click Enable all, click Apply.
- Check Hide all Microsoft services, click Disable all, locate and check: Parallels Coherence Service and Parallels Tools Service (so 2 Parallels services should be checked), click Apply.
- In the Startup tab click Open Task Manager. Here disable all the processes except Parallels Control Center (it may be called prl_cc).
- Reboot virtual machine.
Check the issue. If it does not help:
Shut down virtual machine, open virtual machine configuration > Security Tab, turn on Isolate Windows from Mac option.
- Start virtual machine and check the issue.
- Contact Parallels Support team if you still experience 'slow Mac performance' issue while using Parallels Desktop.
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