User portal not loading due to cookies limit

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Symptoms

Connection to User Portal doesn't work due to the amount of domain-wide cookies created by other portals on the same domain, giving the following error:

Cause

The RAS Proxy Gateway tunnels the HTTP traffic and analyses the data going through it to properly distribute the requests to the appropriate stakeholders. User Portal makes use of a single cookie and the buffer to analyze the data is set to 3072 bytes. If other portals are on the same domain and use domain-wide cookies, these cookies are also sent to User Portal. Once the buffer limit is reached, users will be presented with an error.

Resolution

The system should dynamically increase the size of the buffer to 4096 if required.

If this size is not enough this value can be increased manually by changing the registry key MaxHttpBufferSize of the type DWORD. This key can be found under HKEY_LOCAL_MACHINE\SOFTWARE\Parallels\2XProxyGateway.
Its value determines the maximum size the buffer can be increased to. The value cannot exceed 20480.

Note: Cookies from other portals are not expected to be sent to User Portal, and although they can be added, it is recommended to set the cookie to the respective portal path to ensure system efficiency. Cookies are sent with each request.

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