Symptoms
Awingu is slow or unresponsive. Connections are dropped.
Cause
Poor network connectivity or performance can be caused by a number of factors.
Try to pinpoint the main cause first by answering these two questions:
- Are all the users affected in the same manner, or just a subset?
- Do the same performance issues occur when accessing the Awingu appliance strictly from the internal network to the Awingu appliance (preferably bypassing the organization's firewall, load balancer, ...)?
This way, any internal network components/configurations could already be ruled out or turn out to be causing the issues.
Below is a checklist of important factors.
Organizational factors (these would impact all users):
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Firewall and load balancer:
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White list traffic from/to Awingu so there is no form of deep inspection (e.g. packet inspection).
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If end users are experiencing brief application session interruptions in Awingu but are able within seconds to resume their application session, it is often caused by a firewall or load balancer terminating connections after a certain timeout (proxy timeout, timeout tunnel, ...).
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Product-specific info:
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HA Proxy on pfSense: Verify the timeout tunnel setting.
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Internet connection: Download/upload speed and latency.
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RDS infrastructure: Does the infrastructure have enough CPU, RAM, disk I/O, bandwidth, ...
End-user factors (these would impact a specific user or a small subset of users):
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Browser: Use the latest version of one of the officially supported browsers.
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Internet connection: Especially download speed and latency are key factors. Collect info using for example this SpeedTest .
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VPN: When using a VPN, this may impact the performance of Awingu - either in a negative way, and in rare cases even in a positive way.
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Software: An antivirus solution might be installed on the end-user's device and act as a firewall, which may also be doing too much packet inspection. Whitelist traffic from/to Awingu.
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Use case: Which applications does the end user typically use?
Do they use graphic-intensive applications such as drawing applications (Adobe Creative Suite, AutoCAD, ...), GIS / mapping applications (ArcGIS, QGIS, OpenStreet Maps, Google Maps, web maps, ...)?
Do they watch a lot of videos? (YouTube, surveillance cameras, ...)
Do they have any other open application which is graphic-related? (e.g. scrolling through a large library of pictures) -
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