Applications / Remote Desktop Sessions closing quickly after opening

1 users found this article helpful

Symptoms

When launching an application session in Parallels Secure Workspace, the session starts. However, is quickly terminated. Usually, the user only briefly sees a black screen.

Cause

Parallels Secure Workspace does not detect any open application windows. This triggers the session disconnection, as it's assumed the user closed all windows.

This is most frequently the case when an application shows a loading splash screen, which then disappears for a short time before opening the actual application.

However, the application is still open on the back-end Remote Desktop Services (RDS) host, so the session continues running there. It may be closed automatically by group policies applied to the RDS hosts.

Resolution

To prevent this, delay the close timeout when no windows are detected in the session.

  1. Navigate to System Settings > Manage > Labels.
  2. Click [Add manually].
  3. There are two different labels which can be added:
    • Key: closetimeout
      Value: specify a value between 5000 and 30000 (milliseconds)
      This label will add (the value in milliseconds) of additional time to wait when opening an application (first window in the session).
    • Key: closetimeoutextended
      Value: specify a value between 5000 and 30000 (milliseconds)
      This label controls the interval after which the session will be closed if no windows are detected since the initial window has opened and closed.  
  4. Assign these labels to the affected application(s) by navigating to System Settings > Manage > Applications. 
    Select the application and add the desired label(s) to the "labels" setting.

Was this article helpful?

Tell us how we can improve it.