Fix black screen issue on a remote Mac

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Symptoms

Cause

Parallels Access or some of the embedded components haven't been granted with the respective permissions in System Preferences of the remote Mac computer.

Resolution

1. On a remote Mac, open System Preferences > Security & Privacy > PrivacyScreen Recording and check the boxes next to Parallels Access and Parallels Access Agent.

2. You will be prompted to restart the application or click Later. Click Later.

3. Terminate the remote connection and try connecting once again.

Advanced steps

If the steps above haven't helped or if Parallels Access Agent is missing in the Screen Recording list, it may be an indicator of further macOS misconfiguration. To fix it, perform the steps below:

1. On your Mac, open Terminal (Finder > Applications > Utilities > Terminal) and execute the following command:

tccutil reset ScreenCapture com.parallels.mobile.prl_deskctl_agent

2. Attempt to re-establish a remote connection using Parallels Access mobile app or a browser. You will still get a blank screen, but on the remote Mac side, you will be presented with a prompt to grant screen recording access to Parallels Access.

3. Click Open System Preferences and check the boxes next to Parallels Access and Parallels Access Agent.
4. Close the remote connection then and try connecting once again.

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