Symptoms
- A published application is failing to launch.
- The problematic app's process appears in RDSH's Task Manager but after 25 seconds, the whole session is logging off.
- From the end user's perspective there are no any errors listed, just nothing happens after launching an app.
- Some generic applications (e.g. Notepad) published from the same RDSH are working without any problems.
- Verbose client log is not indication any errors, only the session disconnect event:
[I 02/00000007/T40F4/P5304/S0008] 25-01-21 12:49:33 - RDP session ended [2][12] .
[T 02/0000003C/T40F4/P5304/S0008] 25-01-21 12:49:33 - End: disconnected 2
[T 02/0000003C/T40F4/P5304/S0008] 25-01-21 12:49:33 - End: disconnected 2
Cause
An app in question requires a lot of time to load (due to the configuration files or other dependencies). By default, RAS is logging off a session if the application did not load the UI within 25 seconds.
Resolution
Increase the disconnection timeout from the default 25 seconds to 1 minute - right-click on an RDSH in RAS Console > Set Publishing Session disconnection timeout to 1 minute.
Was this article helpful?
Tell us how we can improve it.