Symptoms
A black screen is observed right after the RDS session login:
Cause
Windows AppReadiness service activity is stalling Desktop appearance. Possibly due to some other bug.
Confirmed to happen in User Profile Disk and AVD + FSLogix environments. Possibly not noticed in usual RDS since it is less affected.
Resolution
Stop and Disable App Readiness service. Login time should improve after this change.
NOTE: App Readiness service may need to be started before installing Windows Updates that require restart.
Known issues with App Readiness service
- Delayed logins in Virtual Desktop environment:
AppReadiness Service and Black Screen - Microsoft Tech Community
- Local Windows 10 delayed logins:
5 min delay on cold start between login screen and bg screen Solved - Page 3 - Windows 10 Forums
Microsoft explains Windows 10 Black Screen login issue, working on fix - MSPoweruser
Windows 10 Black screen forever when logging in - Spiceworks
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