Parallels Mac Management components system requirements

0 users found this article helpful

Information

Minimal system requirements for Parallels Mac Management components are:

Note: With release of SCCM 1702 Microsoft has deprecated Windows Server 2008, so in order to be future proof it's recommended to use Windows Server 2012 or above.

Was this article helpful?

Tell us how we can improve it.