Symptoms
- TWAIN scanners are failing to redirect and not being listed at Connection Properties > Scanning > TWAIN.
- To fix this, one needs to launch Parallels Client as Administrator.
- Procmon capture (gathered after reproducing the issue) contains the following entries:
2XClientScan.exe 4080 2120 CreateFile C:\Program Files\Parallels\Client\x86\twain_32.dll NAME NOT FOUND Desired Access: Read Attributes, Disposition: Open, Options: Open Reparse Point, Attributes: n/a, ShareMode: Read, Write, Delete, AllocationSize: n/a 8:54:42.4023958 PM
2XClientScan.exe 4080 2120 CreateFile C:\Windows\SysWOW64\TWAIN_32.DLL SUCCESS Desired Access: Read Attributes, Disposition: Open, Options: Open Reparse Point, Attributes: n/a, ShareMode: Read, Write, Delete, AllocationSize: n/a, OpenResult: Opened
Cause
OS misconfiguration. Either environment variables are missing or an outdated twain_32.dll file prevents Parallels Client from successful operation.
Resolution
1. Make sure that environment variables set correctly at Control Panel > System > Change settings > Advanced > Environment Variables
Path for TEMP and TMP must be set correctly (as shown on the screenshot below):
2. Check that there is no twain_32.dll file in C:\WINDOWS\SYSWOW64 directory. If the file persists there, delete it.
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