No printers are redirected with RAS Universal Printing technology

0 users found this article helpful

Symptoms

No printers are redirected with RAS Universal Printing technology.

The following entry can be found in tsagent.log:

[E 08/0000000A/T14A8/P101C] 09-12-19 13:15:10 - Failed to add printer: name='Send To OneNote 2016 for user by Parallels', port='XXPortS0009P0000', driver='2X Universal Printer', type='NT EMF 1.008' (Access denied.   [0x00000005])

Cause

This is caused by the RAS RD Session Host Agent services being started under the domain account.

Resolution

To resolve this issue please change the Log On As for the RAS RD Session Host Agent service to Local System account:

1. Right-click the Start menu and click Run:

 

2. At the opened window type services.msc and click OK:

3. Scroll to RAS RD Session Host Agent, right-click it and click Properties:

4. Switch to Log On tab and change Log on as to the Local System account

5. Log off the affected user session and start the published item again.

Was this article helpful?

Tell us how we can improve it.