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Cannot install Parallels Tools

APPLIES TO:
  • Parallels Desktop 10 for Mac
  • Parallels Desktop 9 for Mac
  • Parallels Desktop 8 for Mac
  • Parallels Desktop 7 for Mac
  • Parallels Desktop 6 for Mac

Symptoms

I cannot install Parallels Tools. Installation hangs, rolls back or stops with or without error message.

Cause

  1. Parallels Tools installation was interfered with by some process in Windows. To minimize the risk of this kind of issue in future please do not perform any operations in Windows while Parallels Tools installation is in progress.

  2. There is a software conflict inside Windows.

Resolution

Follow these troubleshooting sections in the same order in which they are presented:



Uninstall & install Parallels Tools

NOTE: We strongly recommend that you make a backup of the virtual machine or create a snapshot before proceeding.

  1. Start your virtual machine and cancel Parallels Tools installation wizard.

  2. Go to Start -> Control Panel -> Programs and Features (Add or Remove programs in Windows XP) and remove Parallels Tools from the list of apps.

  3. Restart Windows.

  4. Install Parallels Tools by clicking on Virtual Machine -> Install Parallels Tools.



Disable antivirus and / or firewall software and 3rd party services

If the issue persists, please try the following:

  1. Uninstall Parallels Tools as per instructions (step 2) in the section above.
  2. Disable/deactivate/stop any firewall and / or antivirus software installed in your Virtual Machine.
  3. Go to Start. Type in in the Search field: msconfig and then launch msconfig application.

  4. When System Configuration window opens switch to Startup tab and uncheck all items listed there

  5. Switch to Services tab, check Hide all Microsoft services and then un-check all remaining 3rd party services in the list

  6. Click Apply an then OK
  7. Reboot your Windows Virtual machine and try to install Parallels Tools again.
  8. If the issue is fixed launch msconfig again and enable all necessary startup items and services



Uninstall, clean up & install Parallels Tools

If the issue persists, please try the following:

  1. Uninstall Parallels Tools as per instructions in the section above.
  2. Go to My Computer > "C" Drive > Program Files(x86**) > Parallels folder and delete the Parallels Tools folder, if present.

  3. Go to Start. Type in in the Search field: regedit and then launch regedit application.

  4. In Registry Editor, go to My Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Parallels and delete the Parallels Tools entry, and go to My Computer\HKEY_CURRENT_USER\SOFTWARE\Parallels and delete the Parallels Tools entry.

  5. Go to Start. Type in in the Search field: cmd and then launch cmd application with administrative privileges.

  6. In Command prompt type in:

    sfc /scannow
    

    press Return and wait till the operation completes.

    if sfc utility reports any errors it is recommended to run it several times rebooting Windows after each attempt.

    Also try the solution from KB 117753

  7. Reboot Windows and try to install Parallels Tools again.



Uninstall, clean up, delete temporary files & install Parallels Tools

If the issue still persists, please try the following:

  1. Run steps 1 to 4 from the section above.
  2. Go to Start. Type in in the Search field: %temp% and hit Return-> select all files and folders under this Temp folder and delete them permanently (also from Recycle Bin).
  3. Go to Start -> Computer -> Local Disk (C:) -> Windows and make sure it contains Temp folder. Make sure a new parallels-tools-setup.xxxxxxxx_xxxxxx.log file (where xxxxxxxx_xxxxxx is a date and time of file creation) created after each attempt to reinstall Parallels Tools.

    If "Temp" folder does not exist inside "Windows" folder please create it manually.

    if a new parallels-tools-setup.xxxxxxxx_xxxxxx.log file is not created after each attempt to install Parallels Tools, rename the existing "Temp" folder (ex.: "Temp.old") and create a new "Temp" manually.

  4. Install Parallels Tools manually by following KB 112609.

    NOTE Launch PTAgent.exe or setup.exe files using Run as Administratoroption (right-click on the file, choose Run as Administrator)




Additional information:

If the steps above do not help to fix the issue please try to use the following Knowledge base article to troubleshoot Parallels Tools installation issues: Parallels Tools Troubleshooting

Search words:

Parallels Tools did not install

install parallels tools

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