Symptoms
- Windows performance is degraded.
- Parallels Tools installation fails.
- Virtual machine frequently crashes.
- I am unable to install application in Windows.
Cause
Windows file system/registry corruption.
Resolution
-
Open Windows Start menu, in Search bar type cmd, right-click on the appeared Command Prompt application and choose Run as Administrator.
- In Command Prompt execute the command below:
chkdsk /f /r
- When asked to schedule checking disk, type y, and press "Enter" again. Reboot Windows and wait until the CHKDSK finishes checking the disk and fix the detected errors if such were found.
-
Open Command Prompt again as Administrator and execute the following command:
sfc /scannow
-
Wait for the scanning and the repairing processes to finish.
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There is a chance you might get the following message at the end of the scanning procedure:
Windows Resource Protection found corrupt files but was unable to fix some of them. Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For example C:\Windows\Logs\CBS\CBS.log. Note that logging is currently not supported in offline servicing scenarios
It means that typical scanning/repairing utility is not enough to fix Windows files corruption, to be able to fix it, please do not close Command Prompt window and proceed with the instructions:
-
In Command Prompt execute the following commands one by one:
DISM /Online /Cleanup-Image /CheckHealth DISM /Online /Cleanup-Image /ScanHealth DISM /Online /Cleanup-Image /RestoreHealth
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In case you have Windows installation media (CD/DVD disk or .iso image), please do the following:
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Make sure Windows is connected to the Internet.
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Insert CD/DVD or put an .iso file to the easiest location on the Mac to use it later.
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From Mac top menu choose Devices > CD/DVD
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If you use physical CD/DVD, choose CD/DVD drive from the list.
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If you use .iso image, choose Connect image... and navigate to the image location.
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Double-click it and check that it appeared inside Windows as drive D:
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In Command Prompt execute the commands from step 7 one by one changed in the following way:
DISM /Online /Cleanup-Image /CheckHealth /source:wim:D:\sources\install.wim:1 /limitaccess DISM /Online /Cleanup-Image /ScanHealth /source:wim:D:\sources\install.wim:1 /limitaccess DISM /Online /Cleanup-Image /RestoreHealth /source:wim:D:\sources\install.wim:1 /limitaccess
where D: is the Windows installation image mounted in a virtual drive.
Wait until the operation is completed. This usually takes 20-30 minutes.
-
Restart the virtual machine.
- If the situation did not change after the restart, the only thing left is to reset Windows.
If Windows updates fail to install, the operating system repair method from the official Microsoft knowledge base may help.
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