Symptoms
- After the upgrade of RAS, the printers/scanners are not being redirected in a remote session.
- It may happen either to all servers or specific ones on the Farm.
- The following agents might be affected: RDSH, Remote PC, Guest (VDI Desktop)
Cause
During the upgrade, the system could not load the new files. Thus some of the important executables (DevRedir.exe and others) are not presented in the RAS installation folder:
"C:\Program Files (x86)\Parallels\ApplicationServer\
Resolution
Repair RAS RDSH/Remote PC/Guest Agent installation on the affected machines and reboot them to restore functionality.
If it fails while attempting to find an installer, please download one on RDSH directly: https://www.parallels.com/products/ras/download/links/
Alternatively, you may reinstall the RDSH Agent role using Powershell or Command Prompt using this command (applies to cases when RDSH Agents is the only component on the server, please test the command before executing on production):
msiexec /i RASInstallerNAME.msi ADDLOCAL=F_PowerShell /qn
Note: If the executables are still being removed immediately or after some time, please make sure all required antivirus exclusions are set following this article
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