Failed to convert guest [VM_NAME]. XenServer tools are not installed

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Symptoms

Cause

XenServer Tools are corrupted/not functioning properly. As a proof you may check if you are able to check the XenServer Tools version by using the XenCenter console:

Execute the command:

xe vm-list

Copy the UUID of the affected VM and execute the command:

xe vm-param-get param-name=PV-drivers-version uuid=XXXXXXXXXXXX

It should show you the Tools version in the output.

Another way to check if Tools are working properly:

In XenCenter, highlight the VM > switch to General tab.

Normally the Virtualization state filed should show you the version of installed Tools and you should be able to use Shut Down/Reboot/Suspend buttons:

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If XenServer Tools are not installed/ not functioning properly, the Shut Down/Reboot/Suspend buttons will be greyed out:

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Resolution

Reinstall Citrix XenServer Tools, make sure that they are listed properly in XenCenter. After that try to create RAS Template once again.

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