Symptoms
When I am trying to check Parallels Desktop for updates, the following error appears:
'Unable to check for updates. Contact the Parallels support team for assistance.'

Cause
Parallels Desktop application cannot connect to parallels.com
Resolution
Open Finder. In the menubar go to Go to folder, type '/etc/', click 'Go'.
Locate 'hosts' file, right-click it > Get info > Expand 'Sharing & Permissions' tab.
Click the lock icon to allow modifying.
Click '+', select your user account.
Under 'Sharing & Permissions' Click 'Read only' near your account name and change it to 'Read & Write'.
Open Terminal (Finder > Applications > Utilities > Terminal)
Execute:
cd /etc vim hosts
Press 'E'.
Locate the strings (using arrows) that contain 'parallels' and press 'DD' (double 'D') to remove them.
- After removing all the 'parallels'-containing strings type ':wq' and hit 'Enter/Return to end the modifying.
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