Symptoms
- I am unable to start Parallels Desktop with an error message:
Unable to connect to Parallels Service. Make sure that the prl_disp_service process is active and it is not blocked by Firewall. For details, please refer to https://kb.parallels.com/en/8089. If the problem persists, contact the Parallels support team for assistance.
Cause
'prl_disp_service' crashes.
Resolution
In order to workaround the crash please try to create test user account on Mac OS X:
Find the virtual machine file:
start Parallels Desktop
in the menu bar at the top go to Window > Virtual machines list
- right-click on the virtual machine name > Show in Finder
Change the permissions:
right-click on WindowsXX.pvm > Get Info
- in the field 'Sharing & Permissions' please change to 'Read & Write' for all users in the list (including 'everyone' and 'staff')
Move your virtual machines to the /Users/Shared/Parallels folder
Create new test Administrator user account:
go to Finder > Applications > System Preferences > Users & Groups
click on '+' to create a new user and called him Test
in the field New Account choose Administrator
set any name with simple password (e.g. 123) and click 'Create User'
- check the option Allow user to administer this computer
Log off from your current user account (Apple logo > Log out)
Log in the new Test user account
- Launch Parallels Desktop and the virtual machine (you may need to choose the way to the virtual machine, it is /Users/Shared/Parallels)
If Parallels Desktop fails to start under new user account, please submit new problem report ID and contact Parallels Technical Support Team for further assistance.