Parallels Desktop for Mac App Store Edition system requirements

17 users found this article helpful

Parallels Desktop for Mac App Store Edition system requirements:

  Minimum
To run most applications such as Microsoft Office, accounting, trading, SAP, Matlab, and more
Best Performance
For graphics-intensive applications, high loads and running multiple virtual machines
Processor

Apple M1 chip, Intel Core 2 Duo, Core i3, Core i5, Core i7, Core i9, Intel Core M or Xeon processor

Apple M1 chip, Intel Core i5, Core i7, Core i9 or Xeon processor
Memory 4 GB of RAM 16 GB of RAM or more
Storage

600 MB for Parallels Desktop application installation

Additional disk space for the guest operating system (at least 16 GB is required for Windows 10)

SSD drive
Graphics Apple M1 chip, Intel, AMD Radeon, or NVIDIA Apple M1 chip, AMD Radeon Pro graphics card
Operating System

macOS Monterey 12 (when released)

macOS Big Sur 11.1 or newer

macOS Catalina 10.15.7 or newer

macOS Mojave 10.14.6 or newer

macOS High Sierra 10.13.6 or newer

macOS Monterey 12 (when released)

macOS Big Sur 11.1 or newer

DirectX 11 requires at least macOS Mojave 10.14, but works best on macOS 10.15.3 Catalina or newer.

Internet connection is required for product activation, updates, and select features.

Supported Systems on Mac with Apple M1 chip

The following operating systems (ARM-based only) are supported for running in a virtual machine.

Supported Systems on Mac with Intel processor

The following operating systems (x86-based only) are supported for running in a virtual machine.

* - Only the version downloaded with help of the Installation Assistant with Parallels Desktop.

** - Parallels Tools are not available for this operating system.

Parallels Tools for Linux require X Window System version 1.15-1.20 and Linux Kernel version 2.6.29-5.12.

Was this article helpful?

Tell us how we can improve it.