Search

Language:  

Available article translations:

Reversión de la instalación de Parallels Tools

APPLIES TO:
  • Parallels Desktop 9 for Mac Standard Edition

Síntomas

La instalación de Parallels Tools se revierte sin mostrar ningún mensaje de error o se obtiene un mensaje de error general acerca de la actualización de Parallels Tools.

Para poder determinar la causa de dicha reversión, es necesario abrir el archivo de registro en C:\Windows\Temp\parallels-tools-setup.log. Este contendrá la siguiente cadena de texto:

    Error code 0xE0000100: The style of the INF is different than what was requested.

Ejemplo:

    DIFXAPP: INFO:   Installing INF file 'C:\Program Files\Parallels\Parallels Tools\Drivers\prl_dd\prl_dd.inf' (Plug and Play).
    DIFXAPP: INFO:   Looking for Model Section ...
DIFXAPP: INFO:   Installing devices with Id "PCI\VEN_1AB8&DEV_4005&SUBSYS_04001AB8&REV_00" using INF "C:\Windows\System32\DriverStore\FileRepository\prl_dd.inf_x86_neutral_caed5e8e38ace253\prl_dd.inf".
    DIFXAPP: INFO:   Will force install because driver is not better and force flag is set.
    DIFXAPP: INFO:   ENTER UpdateDriverForPlugAndPlayDevices...
DIFXAPP: ERROR:  RETURN UpdateDriverForPlugAndPlayDevices. (Error code 0xE0000100: The style of the INF is different than what was requested.)`

Nota: Aquí, el componente prl\_dd.inf\_x86\_neutral\_caed5e8e38ace253 solo es un ejemplo. Examine parallels-tools-setup.log ara descubrir el componente exacto que no puede instalarse en su caso.

Causa

Uno o varios archivos que contienen la caché para los controladores de Parallels han resultado dañados como resultado de un apagado incorrecto de la máquina virtual o un bloqueo durante la instalación de Parallels Tools.

Resolución

Nota: Le recomendamos encarecidamente realizar un backup de su máquina virtual antes de realizar los pasos detallados a continuación.

Nota: esta solución solo es válida para Windows 7

Sección 1.

  • Actualice su Windows 7 a Windows 7 Service Pack 1.
  • Reinicie Windows y compruebe si sigue experimentando la incidencia. De ser así, realice los pasos descritos en la Sección 2.

Sección 2.

  • Elimine Parallels Tools mediante el Panel de Control.
  • Reinicie Windows en su máquina virtual.
  • Vuelva a instalar Parallels Tools mediante el menú de Parallels Desktop, Para ello vaya a Máquina Virtual --> Instalar Parallels Tools.
  • Si aún así sigue experimentando el problema, consulte la Sección 3.

Sección 3.

Intente usar DPInst:

3.1. Descargue dpinst.exe (o dpinst64.exe en el caso de Windows de 64 bits) y guárdelo en alguna ubicación a la que pueda accederse desde Windows.

3.2. Abra Símbolo del sistema (en Windows, vaya al menú Inicio y busque Símbolo del sistema).

3.3. Tipo:

    cd /d <path to directory with dpinst>

3.4. En el Explorador de Windows, abra la carpeta C:\Windows\system32\DriverStore\FileRepository.

3.5. Se le mostrarán varias carpetas de controladores. Localice la carpeta prl_pv* (tenga en cuenta que puede existir más de una):

prl_pv folders

3.6. Acceda a esta carpeta.

3.7. En la ventana del símbolo del sistema, introduzca lo siguiente:

    dpinst /d /u 

O bien introduzca dpinst64 en el caso de Windows de 64 bits.

3.8. Desde la ventana del Explorador de Windows, arrastre el archivo .inf de la carpeta prl_pv a la ventana del símbolo del sistema para que así la ruta se escriba automáticamente:

DnD

3.9. Presione la tecla Enter. Podrá ver una ventana de confirmación. Haga clic en .

3.10. Repita los pasos 4.6. a 4.9. para cada carpeta prl_pv encontrada.

3.11. Reinicie la máquina virtual e intente instalar Parallels Tools de nuevo (también puede usar msconfig para desactivar todos los servicios de terceros y los elementos de arranque y aislar Windows de Mac antes de reiniciar).




1e5db16426987d561060acdf56d947b4 df4909b7dd0609a3c148f007041db6d9 3307fff3682b15f0ba3fbe13d779296d

FEEDBACK
Was this article helpful?
Tell us how we may improve it.
Yes No