Search

Language:  
Search for:

Available article translations:

No puedo conectar una impresora de red Canon después de actualizar a Snow Leopard

APPLIES TO:
  • Parallels Desktop 5 for Mac Standard Edition
  • Parallels Desktop 4 for Mac Standard Edition

Síntomas

Una vez realizada la actualización a Mac OS X 10.6 Snow Leopard, no se detecta su impresora de red Canon u obtiene un 'Error de comunicación' procedente de la impresora si tiene instalado Parallels Desktop. Si desinstala Parallels Desktop, entonces la impresora se detecta sin ningún tipo de problema y puede realizar impresiones sin obtener ningún error.


Nota:  Las impresoras Canon no funcionan correctamente en Mac OS X . Si experimenta cualquier incidencia relacionada con una impresora que no funciona en una máquina virtual en Windows, consulte este artículo



Causa

La causa de esta incidencia es un conflicto entre la conexión de red de Parallels Desktop y el plugin de detección de red de Canon en Snow Leopard.

Resolución

Para resolver este conflicto, actualice a Parallels Desktop 5 para Mac y compruebe que tiene instalada la actualización Mac OS X Snow Leopard  10.6.2 (o posterior) y el controlador más reciente de Canon.  Este conflicto ha sido resuelto por parte de Apple a través de la Actualización 10.6.2. para Snow Leopard y funciona con Parallels Desktop 5 para Mac.

En el caso de Parallels Desktop 4.0, compruebe que dispone de los controladores de impresora de red Canon más recientes. Puede comprobar su disponibilidad en el sitio web de Canon.

Si tiene instalados los controladores más recientes y sigue experimentado este problema o Canon aún no ha actualizado los controladores para su dispositivo, existe una solución alternativa para usuarios avanzados de Mac OS X. Esta solución implica la desactivación de la conexión de red compartida de Parallels Desktop para el uso de una conexión de red en modo bridge. Para aplicar esta solución alternativa, haga lo siguiente:

1) En la configuración de su máquina virtual, cambie de Conexión de red compartida a Conexión de red en modo bridge.

2) Abra Terminal (Aplicaciones > Utilidades>Terminal) y copie/pegue los siguientes comandos:

sudo killall prl_naptd

sudo kextunload com.parallels.kext.prl_vnic

sudo mv /Library/Parallels/Parallels\ Service.app/Contents/Kexts/10.6/prl_vnic.kext /Library/Parallels/Parallels\ Service.app/Contents/Kexts/10.6/prl_vnic.kext.backup

Se le pedirá su contraseña administrativa, aunque no podrá verla mientras la introduzca.

3) Intente volver a conectar su impresora Canon.


Nota: La realización de estas acciones es de su responsabilidad. Si no está seguro acerca de cómo ejecutar los comandos indicados, es mejor actualizar a Parallels Desktop 5 para Mac.


Para volver a pasar a Conexión de red compartida, simplemente desinstale Parallels Desktop y vuelva a instalarlo.



df4909b7dd0609a3c148f007041db6d9 1e5db16426987d561060acdf56d947b4 d6e04a8c3a7f86de03d4731caa56d4ed 38f7bd743dfc92af584ba5b137dce6dc

FEEDBACK
Was this article helpful?
Tell us how we may improve it.
Yes No