Product:
Search Type:

[FIX] Error managing/removing a mailbox

Article ID: 977 
Last Review: Feb,12 2008
APPLIES TO:
  • Plesk 7.5.x for Windows
  • Plesk 8.1 for Windows
  • Plesk 8.2 for Windows
  • Plesk 8.3 for Windows

SYMPTOMS

The following error message is received when attempting to manage (update password or remove) a mailbox using Plesk:

Unable to remove the mail names: mailmng failed: MEAOPO.Mailbox.GetMailbox failed
MEAOPO.Mailbox.RemoveMailbox failed
MEAOAM.AddressMap.RemoveAddressMap failed for domain domain.tld [domain.tld

or

MEAOPO.Mailbox.GetMailbox failed

    at (MailEnable::MailEnableMailName::MailEnableMailName line 92)

    at execute console command --set-password(vconsoleapp::start line 128)

    at execute "C:\Program Files\SWsoft\Plesk\admin\bin\mailmng.exe"

--set-password "--domain-name=domain.tld" "--mailname=joedoe"

"--password=stereotype"(vconsoleapp::run line 138) Execute file name: C:\Program Files\SWsoft\Plesk\admin\bin\mailmng.exe

CAUSE

Most likely that the mailbox or the mail domain are missing from MailEnable configuration.

RESOLUTION

The configuration can be restored using the following command:


"%plesk_bin%\mchk.exe" --domain --domain-name=domain.tld


This utility will reconfigure MailEnable records according to Plesk database. After reconfiguration the mailbox can be managed safely.

Please provide feedback on this article

Did this article help you solve your issue?
Yes
No
Partially
I do not know yet
 
Strongly Agree   Strongly Disagree
  9 8 7 6 5 4 3 2 1
The article is easy to understand
The article is accurate
Additional Comments:
*Please provide us with your email address in case we need to contact you.
*Please type the code you can see.
* - required fields