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Problem with Logitech keyboard and mouse after Parallels Desktop upgrade

APPLIES TO:
  • Parallels Desktop 7 for Mac
  • Parallels Desktop 6 for Mac
  • Parallels Desktop 5 for Mac
  • Parallels Desktop 4 for Mac

Symptoms

After upgrading Parallels Desktop for Mac you can meet Logitech mouse or keyboard performance problems.

For example, when scrolling on the Windows side without moving a mouse pointer you can notice, that the pointer became black (the way it appears when you work on Mac side). Also it could be impossible to select multiple items by scrolling down. Sometimes the mouse could jump not following your commands.

Sometimes Parallels Desktop starts displaying a message saying that it can not enter Coherence mode since the mouse is not synchronized.

Cause

Usually such behavior appears if Logitech Control Center is installed on Mac. It conflicts with Parallels Desktop application and needs to be fully reinstalled in order to fix the issue.

You may find similar reports, but on different applications, in this Apple forum thread.

Resolution

Reinstall Logitech Control Center on your Macintosh computer:

1) Stop all the virtual machines

2) Start Terminal utility (Finder -> Applications -> Utilities -> Terminal) and copy/paste the following commands there one-by-one (hit Return after each of them):

sudo rm -r /System/Library/Extensions/Logitech*

sudo rm -r /Library/Application\ Support/Logitech

3) Type in your password when asked

NOTE: you will not see the password  when typing it.

4) Close the Terminal and restart your Mac.

5) Start the virtual machine and reinstall Parallels Tools.

6) Check if the problem is still there.

7) Install the Logitech Control Center back and if the problem reappears, contact Apple.



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