Search Type:
Search for:

Language:

Product:
Category:
No categories for selected product

How To Remove Parallels Desktop 4 Completely?

Article ID: 5714 
Last Review: Nov,20 2009
Author: Ivan Chega
Last updated by: Ivan Chega APPLIES TO:
  • Parallels Desktop for Mac 4.x

Symptoms

Errors occur when you try to install or update Parallels Desktop, create or open virtual machines, load the required drivers to the guest OS.

Cause

Mac OS system failure or incorrect software update may result in inability to install Parallels Desktop or load system files properly. Working in Mac OS for long periods of time without restart may lead to some minor glitches to appear in the system in total.
In such cases you might need to remove Parallels Desktop from your system completely and perform a clean installation.

Resolution

To resolve these issues, do the following:

1. Reboot your Mac.

2. Launch Applications --> Utilities --> Disk Utility.

3. Select Macintosh HD on the left tab and click the Repair Disk Permissions button.

4. Launch the Uninstall Parallels Desktop application (you can find it on the Parallels Desktop CD or in the downloaded Parallels Desktop DMG package) and follow the on-screen instructions. Please note that Parallels Uninstaller does not remove virtual machines from your Macintosh hard disk. It is important to use the Uninstaller of the Parallels Desktop version currently installed or newer.

5. Launch Applications --> Utilities --> Terminal and type the following commands:

NOTE! Please be sure to enter the commands in the full form because in case of missing any Mac OS can be corrupted.

cd /Library/
sudo rm -rf Parallels
cd /Library/Preferences/
sudo rm -rf Parallels
cd /Library/StartupItems/
sudo rm -rf ParallelsTransporter
cd /System/Library/Extensions/
sudo rm -rf prl_hid_hook.kext
sudo rm -rf prl_hypervisor.kext
sudo rm -rf prl_vnic.kext
sudo rm -rf prl_usb_connect.kext
sudo rm -rf prl_netbridge.kext
cd /Users/<username>/
sudo rm -rf .parallels/
sudo rm -rf .parallels_settings

Do not  forget to replace <username> with a real name of account (it should not contain spaces) !
If some commands are showing “No such file or dir” – it means that uninstaller deleted them already and this is normal.

6. Repeat steps 2 and 3.

7. Restart your computer again

8. Eject Parallels Desktop installation CD - if you performed uninstall process from CD.

For information on removing Parallels Desktop 3.0, please check http://kb.parallels.com/4709
For information on removing Parallels Desktop 5.0, please check http://kb.parallels.com/en/6904



Subscription for changes to this article Subscription for changes to this article

Please provide feedback on this article

Did this article help you solve your issue?
Yes
No
Partially
I do not know yet
 
Strongly Agree   Strongly Disagree
  9 8 7 6 5 4 3 2 1
The article is easy to understand
The article is accurate
Additional Comments:
*Please provide us with your email address in case we need to contact you.
* - required fields
 
 
 
 
 
 
For Home
For Business
For Hosters
For SaaS
For Developers
 
Desktop Virtualization
- Parallels Desktop Switch to Mac Edition
- Parallels Desktop for Mac
- Parallels Desktop 4 for Windows & Linux
- Parallels Workstation Extreme
- Parallels Solution for Windows 7
Server Virtualization
- Parallels Server for Mac
- Parallels Server 4 Bare Metal
- Parallels Virtuozzo Containers
Automation
- Parallels Operations Automation
- Parallels Business Automation
- Parallels Virtual Automation
- Parallels Plesk Panel Suite
More Products