Product:
Search Type:

Expand returns the following error during communication with Plesk server: "Bad HTTP answer code. Plesk server is unreachable now: HTTP answer code is 302 instead of 200(OK)."

Article ID: 4031
Last Review: Mar,24 2008
APPLIES TO:
  • Plesk Expand

SYMPTOMS

Any Plesk server related action in Expand, such as domain creation, client creation, etc... fails with the following error:

<errcode>2003</errcode>
<errtext>[Transport] Bad HTTP answer code. [Transport] Bad HTTP
answer code. Plesk server is unreachable now: HTTP answer code is 302
instead of 200(OK).



CAUSE

Such error occurs if Plesk server, that is managed by Expand, is instailled in Virtuozzo CT and offline management option is enabled for this CT.


RESOLUTION

Here is information from Expand release notes:

It is recommended that you disable the 'offline management' option for Plesk servers running in Virtuozzo CT. Otherwise, you might have problems using features like 'Login to Plesk server', 'Centralized Mail', etc.

Disable offline management for the Plesk CTs that are registered in Expand.

In Parallels Virtuozzo Container for Linux it can be done with:
vzctl set 101 --offline_management=no --save


and in Parallels Virtuozzo Container for Windows:
vzctl set VEID –offline_management no –save




Please provide feedback on this article

Did this article help you solve your issue?
Yes
No
Partially
I do not know yet
 
Strongly Agree   Strongly Disagree
  9 8 7 6 5 4 3 2 1
The article is easy to understand
The article is accurate
Additional Comments:
*Please provide us with your email address in case we need to contact you.
*Please type the code you can see.
* - required fields