Product:
Search Type:

[FIX] Plesk Control Panel does not work after Crystal Reports installation

Article ID: 3030 
Last Review: Nov,02 2007
APPLIES TO:
  • Plesk for Windows

SYMPTOMS

Plesk Control Panel does not work after Crystal Reports installation.

The following error is displayed:

Fatal error:  EVP_VerifyInit failed in C:\Program Files\SWsoft\Plesk\admin\auto_prepend\auth.php3 on line 40

The error appears only in case Plesk Control Panel running on IIS. If Apache is used as control panel provider, Plesk works normally.

CAUSE

Crystal Reports replaces C:\Windows\System32\libeay32.dll and C:\Windows\System32\ssleay32.dll files which were installed by Plesk.  The libraries which are shipped with Crystal Reports are not compatible with Plesk.

RESOLUTION

Please replace mentioned libraries back. Simply copy ones from %plesk_bin% folder to C:\Windows\System32

Additional information

%plesk_dir% is environment variable which points to Plesk installation folder. By default it is C:\Program Files\SWsoft\Plesk

%plesk_bin% is environment variable which points to Plesk binaries folder. By default it is C:\Program Files\SWsoft\Plesk\admin\bin


Please provide feedback on this article

Did this article help you solve your issue?
Yes
No
Partially
I do not know yet
 
Strongly Agree   Strongly Disagree
  9 8 7 6 5 4 3 2 1
The article is easy to understand
The article is accurate
Additional Comments:
*Please provide us with your email address in case we need to contact you.
*Please type the code you can see.
* - required fields