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[FIX] Plesk Control Panel works slowly

Article ID: 2212 
Last Review: May,29 2008
APPLIES TO:
  • Plesk 8.x for Windows

SYMPTOMS

Plesk Control Panel works slowly.

CAUSE

Reason 1

Jet is used as Plesk database engine. Most likely the reason of the problem is large Plesk database file psa.mdb. This could be caused by number of empty records in this database. Empty records appear when any entries are removed from database – this is standard behavior of DB4 databases.

Reason 2

Long time of login in to Plesk Control panel might be caused by huge  number of records in  “Sessions” table of Plesk database.

RESOLUTION

Solution 1
  • Stop Plesk Control Panel and Plesk Management services.
  • Please use the following VBS script to compress psa.mdb file (it is necessary to create file e.g. script.vbs, and paste provided below text there, then run just created script.vbs): 
Set Engine = CreateObject("JRO.JetEngine")  
Engine.CompactDatabase "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=psa.mdb", _ 
    "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=compressed_psa.mdb"

  • Rename psa.mdb to psa.mdb_old 
  • Rename compressed_psa.mdb to psa.mdb 
  • Start Plesk Control Panel and Plesk Management services
Solution 2

It is necessary to erase the table by the following command:

"%plesk_bin%\dbclient.exe" --direct-sql" --sql=delete from `sessions`"

Additional information

%plesk_dir% is environment variable which points to Plesk installation folder. By default it is C:\Program Files\SWsoft\Plesk.  
%plesk_bin% is environment variable which by default points to C:\Program Files\SWsoft\Plesk\admin\bin.

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