Product:
Search Type:

I removed an IP from the VE with Plesk but it still presents in the Plesk control panel. How can I delete it?

Article ID: 2149 
Last Review: Sep,04 2007
APPLIES TO:
  • Plesk for Linux/Unix

SYMPTOMS

An IP has been removed from the VE but if I go to Server -> IP Addresses in Plesk control panel the IP address still presents and is marked as missing in the system.

CAUSE

At this time Plesk does not allow to manage IP adresses in VE. This functionality will be added in further Plesk versions.

RESOLUTION

At first, make sure that no domains are hosted on this IP and this IP is not added into any client's IP pool. Then try to remove it from root console with command (replace IP_ADDRESS with the real IP):

/usr/local/psa/bin/ipmanage.sh -r IP_ADDRES

Additional information

Such IP addresses can also be removed from the PSA database manually. At first, make sure that no domains are hosted on this IP and this IP is not added into any client's IP pool.  After that run the mysql query as on example below (replace IP_ADDRESS with the real IP:

# mysql -uadmin -p`cat /etc/psa/.psa.shadow` -Dpsa -e "delete from IP_Addresses where ip_address = 'IP_ADDRESS';"

Please provide feedback on this article

Did this article help you solve your issue?
Yes
No
Partially
I do not know yet
 
Strongly Agree   Strongly Disagree
  9 8 7 6 5 4 3 2 1
The article is easy to understand
The article is accurate
Additional Comments:
*Please provide us with your email address in case we need to contact you.
*Please type the code you can see.
* - required fields