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[FIX] Sitebuilder isn’t integrated with Plesk

Article ID: 2114 
Last Review: Nov,01 2007
APPLIES TO:
  • Sitebuilder 4.0 for Windows
  • Plesk 8.2.0 for Windows

SYMPTOMS

Sitebuilder isn’t integrated with Plesk. Component management page shows :

SiteBuilder for Windows 4.0.253 not activated

Event Viewer shows the following error:

Sitebuilder account validation is failed in Sitebuilder: System.Net.WebException: The request failed with HTTP status 400: Bad Request.
   at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at WSAccount.AccountWebService.GetAccountByName(String username)
   at SBNETProxy.Provider.validateAdminAccount(String& status, String& accounttype, String& accountId)
Execute file name: C:\Program Files\SWsoft\Plesk\admin\bin\defpackagemng.exe

However Sitebuilder itself works properly and can be accessed

CAUSE

Most likely the reason of the problem is that Sitebuilder website runs on the different IP than it has configured in registry.

RESOLUTION

Please open regedit and go to the following key :

HKEY_LOCAL_MACHINE\SOFTWARE\SWsoft SiteBuilder for Windows

Ensure that value CREATEDWEBSITEIP points to the same IP address as Sitebuilder website has in IIS.

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