Product:
Search Type:

I get the following error during Plesk server adding to Expand: "The Plesk server is currently unavailable. Please check the Plesk installation, its operation or network status."

Article ID: 1889 
Last Review: May,29 2007
APPLIES TO:
  • Expand 2.x

SYMPTOMS

I'am trying to add Plesk server to Expand, but get the error that the connection to Plesk server cannot be established:

The Plesk server is currently unavailable. Please check the Plesk installation, its operation or network status

CAUSE

This error means that Expand cannot even establish  HTTPS connection to the Plesk server. There are can be different reasons, from Expand/Plesk misconfiguration to the Network problems.

RESOLUTION

- First of all make sure that Plesk CP is running and you can access it as https://PLESK_HOSTNAME:8443 and login as admin with the same password that you use to register the Plesk server in Expand.

- Check that access to Plesk CP from Expand server is not blocked on the Server->Access page in Plesk CP.

- Make sure that connection to PLESK_HOSTNAME:8443 is not blocked with firewall and you are able to get the Plesk index page with 'curl' by running the following command on the Expand server:
# curl -k https://PLESK_HOSTNAME:8443


- Try to disable 'selinux' on the Expand server:
# setenforce 0

and check if it helps. If yes, please reinstall expand-selinux-support package and try to add Plesk server to Expand again.

Please provide feedback on this article

Did this article help you solve your issue?
Yes
No
Partially
I do not know yet
 
Strongly Agree   Strongly Disagree
  9 8 7 6 5 4 3 2 1
The article is easy to understand
The article is accurate
Additional Comments:
*Please provide us with your email address in case we need to contact you.
*Please type the code you can see.
* - required fields