[FIX] VZPP login goes to a loop.

Article ID: 1837 
Last Review: Oct,6 2008
Author: Basalyko Roman APPLIES TO:
  • Virtuozzo for Windows 3.5.1 SP1

Symptoms

When I try to login to Virtuozzo Power Panel (VZPP), it accepts my credentials but continues logging in a loop.

Cause

A resource shortage within the VE will cause this behavior.  As the VZPP is loading, it checks if Plesk is installed within the VE.  When the memory and/or number of processes limits are reached, an error message is generated and the VZPP doesn’t load.

Resolution

This issue will be addressed in the Virtuozzo 4.0 release.  Until its release, a workaround exists:

Open the following file c:\vz\private\1\root\Program Files\SWsoft\vzcp\etc\pp\menu.xml and remove the following section:

 
<item href="$baseurl/panel/plesk" icon="plesk" tip="plesk_screen" cred="plesk_control_panel" cond="$layout != 'plesk-integrated'" svps="deny">

<title>Plesk Control Panel</title>

<screen id="07.04.03.01"></screen>


</item>   




Note:  When the workaround is applied, no Plesk button will be within any VZPP. 

Note: When SVE is recreated all settings will be returned to default.



Subscription for this article changesSubscription for this article changes

Please provide feedback on this article

Did this article help you solve your issue?
Yes
No
Partially
I do not know yet
 
Strongly Agree   Strongly Disagree
  9 8 7 6 5 4 3 2 1
The article is easy to understand
The article is accurate
Additional Comments:
*Please provide us with your email address in case we need to contact you.
* - required fields