SYMPTOMS
DrWeb service returns the following startup error:Plesk authorization failed: HTTP request error [6]
Error: Plesk Software not running.
CAUSE
DrWeb package that comes with Plesk distributive is configured to work with Plesk CP and cannot be run standalone. It searches Plesk CP on localhost:8443 for authorization and if this attempt fails, the error listed above occurs.RESOLUTION
Make sure that Plesk CP is running on 8443 port and you are able to establish connection to it:
#telnet localhost 8443
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
If you get the error from the command above, the reason can be:
- localhost cannot be resolved or resolved incorrectly, make sure that localhost entry exists in /etc/hosts.
127.0.0.1 localhost localhost.localdomain
- if you see connection refused error, try to start Plesk and make sure that there is no firewall running on the server that blocks 8443 port.
- also check that Plesk is configured to run on the 8443 port, Listen 8443 directive must be in the $PRODUCT_ROOT_D/admin/conf/httpsd.conf.
- check that you are able to login to Plesk CP in usual way via browser.
- finally make sure that Plesk is responding on DrWEB request by running the following command on the Plesk server, it should be:
# curl -d "challenge=123&checker=drweb" https://localhost:8443/check-plesk.php -k
response=%7BS%D0%18%A5%F1%CF6Z%13%26%.....