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The following error appears in Mailman web interface: "We're sorry, we hit a bug!"

Article ID: 1645 
Last Review: Jan,16 2007
APPLIES TO:
  • Plesk for Linux/Unix

RESOLUTION


SYMPTOMS:

You get the following message in Mailman web interface:

Bug in Mailman version 2.1.5
We're sorry, we hit a bug!
Please inform the webmaster for this site of this problem. Printing of traceback and other system information has been explicitly inhibited, but the webmaster can find this
information in the Mailman error logs.


CAUSE:

This message can be caused as internal Mailman problem (BUGs) as various misconfigurations.


RESOLUTION:

- First of all make sure that Mailman package is not damaged using:


# $MAILMAN_ROOT_D/bin/check_perms
# rpm -V mailman


if you see that some permissions are invalid use "check_perms -f" to fix them.
If some files are missing or corrupted, reinstall mailman RPM.

If it doesn't help look into /var/log/mailman/error for detailed error description.

- If the log shows:

raise Errors.MMCorruptListDatabaseError, e
Mailman.Errors.MMCorruptListDatabaseError: [Errno 2] No such file or
directory: '/var/lib/mailman/lists/mailman/config.db.last'

it means that the list config was damaged and need to be restoredfrom backup.
In case if the error is related to the "mailman" list as stated in the message above you may delete it and recreate as described in the 1639.



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