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[FIX] Protected folders are not working

Article ID: 1358 
Last Review: Aug,05 2008
APPLIES TO:
  • Plesk 7.6.x for Windows
  • Plesk 8.1 for Windows
  • Plesk 8.x for Windows

SYMPTOMS

A folder configured as protected on a domain can be accessed without any authorization.

CAUSE

1. Plesk ISAPI filter for protected directories is not configured on the web site.

2. The web site server ID is not equal to server id stored in the Plesk database.

3. Misconfiguration in Plesk database.

RESOLUTION

1. Check whether urlprotect.dll ISAPI filter is enabled on a web site in IIS.
IIS, Web sites, domain.com, Right Click, Properties, ISAPI Filters, urlprotect.dll

2. Check web site id in IIS.

IIS, Web sites, Find problem web site in list , Identifier is on the right from site name. Or use command line utility

"%plesk_bin%\websrvmng" --get-server-id --vhost-name=domain.com
Then you need to check server id in Plesk DB.

select server_id from hosting h, domains d where h.dom_id=d.id and d.name='domain.com';
If received values are not equal you need to synchronize them

"%plesk_bin%\websrvmng" --update-all-server-id


 Then restart Plesk Management Service.

3. If two previous steps did not help check table `protected_dirs` in Plesk DB. There should be no records with empty value in field path.

select * from protected_dirs where path='';
If any rows were returned they should be removed.

delete from protected_dirs where path='';

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