Error while activating Parallels Desktop for Mac using the command line: Failed to install the license

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NOTE: If you're trying to activate Parallels Desktop for Mac Business Edition, make sure the license key you're using is registered in your Parallels business account. Visit KB 122801 and KB 122802 for detailed instructions on creating a Parallels business account and registering a license key.


Symptoms

When I'm trying to activate an instance of Parallels Desktop for Mac using the command:

    prlsrvctl install-license -k SND0QV-5H035R-ZZEM...

where SND0QV-5H035R-ZZEM... is my Parallels Desktop for Mac license key, I'm getting the error message:

Failed to install the license: Unable to perform the operation. The license server cannot process the request.

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The error may occur in case of using the commands:

    prlsrvctl update-license

or

    prlsrvctl activate-license-online

Cause

  1. The Parallels Desktop for Mac Business Edition license you are using is not registered under your account.

  2. You are not signed in to your Parallels account (for non-business licenses).

Resolution

If you're activating Parallels Desktop for Mac or Parallels Desktop for Mac Pro Edition, ensure that you have signed in to your user account in the Parallels cloud.

To ensure the valid sign-in status enter the command:

    prlsrvctl web-portal signin user1@example.com

where user1@example.com is the email of your Parallels user account. Type your Parallels account password when prompted.

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Alternatively you may check your sign-in status in Parallels Desktop for Mac:

  1. Open Parallels Desktop.

  2. If you see the Sign In screen, select the I have a password option, then enter your existing Parallels user account email and password, and click the Sign In button.

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    If you don't have a Parallels user account yet, select I am a new user, type an email address that will be associated with your new user account, then click on Sign In.

    Fill out the registration form and click the Create Account button.

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  3. If you were not prompted to sign in when you opened Parallels Desktop (as described in step 2), click the Parallels Desktop icon menu item and choose About Parallels Desktop.

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  4. Click on Account & License.

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  5. The Activate Parallels Desktop dialog will appear.

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  6. Click the user account email address in the upper right corner and choose Sign Out. When the confirmation dialog appears, click Sign Out.

  7. Complete step 2 to sign in to your Parallels account.

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