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Error 1719 windows installer service could not be accessed

APPLIES TO:
  • Parallels Desktop 9 for Mac Standard Edition
  • Parallels Desktop 8 for Mac Standard Edition
  • Parallels Desktop 7 for Mac Standard Edition

Symptoms

Unable to install Parallels Tools.

Installation fails on 15% or 20% .

The error message appears: "Error 1719: The Windows Installer Service could not be accessed".

Same error is seen in installation logs (located in C:\Windows\Temp).

Cause

Windows Installation Service fails to start because of system files misconfiguration/corruption.

Resolution

To start the Windows Installer Service, follow these steps:

  1. Click Start, and then type CMD in the Search programs and files dialog box.
  2. Right-click cmd.exe, and then choose Run as Administrator.
  3. Type net start MSIServer, and then press ENTER.

To check that the Windows Installer Service is running, follow these steps:

  1. Click Start, type services.msc in the Search box, and then click Services under the Programs heading.
  2. In the Services (Local) list, right-click Windows Installer, and then click Properties.
  3. In the Startup type drop-down list, check that the value is set to Manual.
  4. The Windows Installer Service is running if the Service status: entry is set to Started.

If attempting to start Windows Installer service fails with the error then required system files are corrupt.

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NOTE: At this point, it is recommended to take snapshot if you haven't already.

Please try istructions from this official Microsoft article.

Other thing you could try is replacing the system files from virtual machine or Personal Computer that does not experience this issue.

NOTE: Windows should have the same version and same bit version (32 / 64). You can find this information following Start > Control Panel > System and Security > System.

  1. Copy the following files on your Mac from the machine that does not experience this issue:

    C:\Windows\system32\msi.dll
    
    C:\Windows\SysWoW64\msi.dll
    

    NOTE: 32-bit version of Windows does not have C:\Windows\SysWoW64 directory. In this case copy only C:\Windows\SysWoW64\msi.dll.

  2. Get Access to your virtual hard drive to paste the files:

    2.1 Open Parallels Desktop and make sure that virtual machine is shut down.

    2.2 Right-click Parallels Desktop icon in the Dock -> click Virtual Machine List.

    2.3 Right-click virtual machine name -> Show in Finder.

    2.4 In the Finder: Right-click virtual machine .pvm file -> Open With -> Parallels Mounter.

    2.5 Virtual machine hard disks will appear in the left Finder tab as external drives.

  3. Locate C:\Windows\system32\msi.dll and C:\Windows\SysWoW64\msi.dll files in the virtual hard disk and rename them to C:\Windows\system32\msi.dll.old and C:\Windows\SysWoW64\msi.dll.old.

  4. Paste the good files.

  5. Eject virtual hard disks from Finder.

  6. Start VM and reinstall Parallels Tools.

Search words:

1719

The Windows Installer Service could not be accessed

Installer

Service

15%

20%

PD




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