Search

Language:  
Search for:

Available article translations:

An error occurred when downloading required components for Parallels Tools installation

APPLIES TO:
  • Parallels Desktop

Symptoms

Parallels Tools cannot be installed on a Virtual Machine with the following output:

Parallels Tools 6.5.23234.964887 Installer started.
2014-03-13T17:39:26+0400: Failed to setup console printk level.
2014-03-13T17:39:29+0400: execCmd: ./installer/pm.sh check_guest_tools 2>&1 [0]

Checking /var/log/parallels-tools-install.log, the following or similar messages can be found:

2014-03-13T15:53:39+0400: Err ftp://ftp.debian.org stable Release.gpg
  Could not resolve 'ftp.debian.org'
...
2014-03-13T15:53:39+0400: Error: An error occurred when downloading required components for Parallels Tools installation.
- gcc
- make
- kernel sources

Cause

The VM has incorrect network settings.

The installation of Parallels Tools requires the access to external resources (OS repositories) to download kernel headers in order to compile the suitable drivers for the current OS. Therefore, the VM should have correct network settings and be able to access the Internet.

Resolution

Apply proper network settings inside the VM.

Search words:

PD




1e5db16426987d561060acdf56d947b4

FEEDBACK
Was this article helpful?
Tell us how we may improve it.
Yes No